Поддержка PHP 4 прекращена

Сообщество разработчиков популярного языка веб-программирования PHP сообщило о прекращении поддержки и дальнейшего развития PHP 4. Первый стабильный релиз этой системы состоялся еще в мае 2000 года. Теперь же для PHP 4 более не будет выпущено никаких патчей и усовершенствований, отмечает CyberSecurity.


В PHP.net говорят, что версия PHP 5 в стабильную ветку была переведена еще два года назад, поэтому все разработчики и владельцы веб-серверов имели достаточно времени для перехода на новую версию.

Разработчики говорят, что нынешняя версия PHP 5.2.6 позволяет практически без изменений работать 95% всем приложениям, написанным на PHP 4, исключения довольно редки и пятая версия имеет все необходимые диагностические средства для выявления проблем и их последующей ликвидации.

Ряд компаний, разрабатывающих свои системы на PHP уже сообщили, что для тех, кто пока не перешел на PHP 5, они продолжат создавать патчи, однако этот процесс не обещает быть долгим.